Telestream Cloud Outage

Incident Report for Telestream Status

Postmortem

Incident Update: Database Write Interruption

Status: Resolved

Summary: Following an automated node restart, the database cluster entered a protective "non-primary" mode, temporarily suspending write operations to ensure data integrity.

Preliminary Findings: The issue was triggered by a quorum loss during the restart process, likely due to a metadata discrepancy involving decommissioned nodes. Engineers manually restored the cluster quorum and verified 100% data consistency.

Next Steps: While all services are fully operational, our team is continuing to investigate the root cause of the configuration discrepancy to prevent a recurrence. A formal RCA will be provided once the investigation is complete.

Posted Mar 04, 2026 - 01:23 UTC

Resolved

The issue is fully resolved.
Posted Mar 03, 2026 - 04:30 UTC

Monitoring

We have resolved issues with DB connectivity - all systems should be operational now. We will continue to monitor.
Posted Mar 03, 2026 - 02:37 UTC

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 02:19 UTC

Investigating

We’re currently experiencing database connectivity issues across all regions, and it appears the entire platform is affected. We are actively assessing the impact and investigating the root cause so we can resolve the issue as quickly as possible.
Posted Mar 03, 2026 - 01:46 UTC
This incident affected: Telestream Cloud (API, Web Console, Workers - AWS, Workers - Azure, Workers - Google Cloud).